Ir para conteúdo
  • Anúncios

    • AiroN

      Anuncie no L2JBrasil

      Deseja anunciar aqui no fórum, no Top L2JBrasil ou em nossa página no Facebook? Confira: www.l2jbrasil.com/anunciar
    • Grundor

      Método de login alterado   08-10-2017

      Com a atualização do fórum para versão  IPB 4.2 não é mais possível fazer login usando username, ao invés disso você deve usar e-mail ou seu Display Name (nome como é exibido no forum).      
    • AiroN

      Tenha seu clube formalmente no L2JBrasil!   18-10-2017

      Você tem amigos que estão sempre juntos contigo na alegria e na tristeza, na saúde e na doença, em todos os desenvolvimentos de suas vida, no pvp, nas quests? rsrs   Monte seu clube formalmente na L2J Brasil!
      Criar um clube é muito fácil, basta você entrar nesse tópico e se interar do assunto:    Dominem o mundo!


      Atenciosamente,
      Administração L2jBrasil.
tlutino

Source L2 Classic L2-Scripts 1.5

Posts recomendados

alguém está tendo problemas para comprar itens? quando compro qualquer item da erro no java. e trava tudo e cai o servidor

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bem bom dia, estou trabalhando nesse projeto quem quiser trocar ideia manda mp.

preciso de ajuda para arrumar as quests o resto eu tenho desbloqueio de ip e geodata agora para mim é moleza

Editado por terry123456
  • Gostei 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bem bom dia, estou trabalhando nesse projeto quem quiser trocar ideia manda mp.

preciso de ajuda para arrumar as quests o resto eu tenho desbloqueio de ip e geodata agora para mim é moleza

traidor :kkk: :kkk: :kkk: :kkk:

  • Gostei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bem bom dia, estou trabalhando nesse projeto quem quiser trocar ideia manda mp.

preciso de ajuda para arrumar as quests o resto eu tenho desbloqueio de ip e geodata agora para mim é moleza

ei brother pode me ajudar?quando eu compilo o projeto aparecem algumas warnings, acredito que seja por conta da versão do java... não entendo muito, mas compila e tals, porém quando entro no game e tento efetuar qualquer comprar qualquer coisa da erro e cai o server. no seu está acontecendo isso tbm?

 

 

(obs:) tentei enviar um mp, mas diz q "esse membro não pode receber novas msgns."

 

Editado por kronas

Compartilhar este post


Link para o post
Compartilhar em outros sites
kronas

Bem ainda n tive tempo de testar tudo pois primeiro vejo conexão externa e interna estou pensando em trocar essa maneira de conexão desse projeto não é pq é complicado e novo e sim pq esta faltando uma porta 2106.

 

Voltando ao assunto esse problema creio eu seja por causa da System a minha esta sem nome em tudo até nas skills, mas hoje irei ver a criação do char tbm esta diferente com alguma restrição que irei verificar hoje, no meu trab e teamviewer expirou e acessar pelo celular é ruim.

 

Manda um print do erro que esta dando no java.

 

 

Ahh esse warnings sim a versão é diferente aos poucos o próprio eclipse ajuda a vc a arrumar não é que tenha tantos erros e sim que existe muitas coisas que n usa mais.

Compartilhar este post


Link para o post
Compartilhar em outros sites
terry123456

 

brother eu testei com a system que o tlutino postou, porém está muito bugada, e dava este erro então tentei com outra system com protocolo 610, mas que está 100% funcional porém mantem o mesmo erro na hora de comprar um item. assim que possivel posto o erro.

  • Gostei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Pelo que vi na source, ela foi descompilada!

 

terry123456

 

brother eu testei com a system que o tlutino postou, porém está muito bugada, e dava este erro então tentei com outra system com protocolo 610, mas que está 100% funcional porém mantem o mesmo erro na hora de comprar um item. assim que possivel posto o erro.

 

Posta screen do erro que tu está tendo.

Compartilhar este post


Link para o post
Compartilhar em outros sites

https://ap.imagensbrasil.org/image/9MwVK

 

esse tipo porem só que achei e o char esta sendo criado no modo de delete (inutilizado) n sei se com alguém esta com isso!!

 

Bem pode ser que eu esteja errado mais pelo que observei ela precisa de muitos incrementos pois eu iria troca a host de conexão e me deparei com muita coisa faltando tipo no script para carregar total e start itens etc falta argumentos de status porem quem quiser mais tarde trab junto na svn que vou abrir ao público aqui em breve.

Editado por terry123456

Compartilhar este post


Link para o post
Compartilhar em outros sites

https://ap.imagensbrasil.org/image/91oDf

 

https://ap.imagensbrasil.org/image/91i8X

 

https://ap.imagensbrasil.org/image/91mVI

 

 

 

 

https://ap.imagensbrasil.org/image/91CKn >>>Versão do java e eclipse indigo

 

 

acha q pode ser alguma coisa de erro por eu estar utilizando o windows 10?

 

 

ali diz erro de falta de memória, mas como isso seria possível?

Editado por kronas

Compartilhar este post


Link para o post
Compartilhar em outros sites

https://ap.imagensbrasil.org/image/91oDf

 

https://ap.imagensbrasil.org/image/91i8X

 

https://ap.imagensbrasil.org/image/91mVI

 

 

 

 

https://ap.imagensbrasil.org/image/91CKn >>>Versão do java e eclipse indigo

 

 

acha q pode ser alguma coisa de erro por eu estar utilizando o windows 10?

 

 

ali diz erro de falta de memória, mas como isso seria possível?

Então, está dando problema de memoria!

Tem quantos MB setado para o Gameserver?

Compartilhar este post


Link para o post
Compartilhar em outros sites

https://ap.imagensbrasil.org/image/91oDf

 

https://ap.imagensbrasil.org/image/91i8X

 

https://ap.imagensbrasil.org/image/91mVI

 

 

 

 

https://ap.imagensbrasil.org/image/91CKn >>>Versão do java e eclipse indigo

 

 

acha q pode ser alguma coisa de erro por eu estar utilizando o windows 10?

 

 

ali diz erro de falta de memória, mas como isso seria possível?

Na hora de comprar coisas do shop está com bug mesmo, tem que achar aonde estar e fixar

 

Não termina de carregar porque não foi configurado corretamente a quantidade de memoria

 

Eu consigo compilar de boa com Windows 10 e a ultima versão do JAVA. Tente usar o Eclipse 3.7.1

Compartilhar este post


Link para o post
Compartilhar em outros sites
Dwbryel

 

eu consigo compilar de boa também, o único problema é esse... dai como não consegui comprar item, nem pude iniciar os testes.

 

 

 

Então, está dando problema de memoria!

Tem quantos MB setado para o Gameserver?

 

 

Então, oque tem de config que deu pra perceber é essa ai...

 

 

REM Ðàçìåð áóôåðà
set JAVA_OPTS=%JAVA_OPTS% -XX:PermSize=128m
set JAVA_OPTS=%JAVA_OPTS% -XX:MaxPermSize=256m
REM Ìèíèìóì è ìàêñèìóì âûäåëÿåìîé ïàìÿòè
REM Ìèíèìàëüíëå çíà÷åíèå äëÿ çàïóñêà ñ ãåîäàòîé: 1.5G
REM Ìèíèìàëüíîå çíà÷åíèå äëÿ çàáóñêà áåç ãåîäàòû: 1G
REM -Xms è -Xmx äîëæíû áûòü âñåãäà ðàâíû äðóã äðóãó.
set JAVA_OPTS=%JAVA_OPTS% -Xmn512m
set JAVA_OPTS=%JAVA_OPTS% -Xms1024m
set JAVA_OPTS=%JAVA_OPTS% -Xmx1024m
tipo eu já alterei isso ai pra 2g, 4g, e 6g mais continua igual,
essa é a config iriginal, do jeito que tá ai, ja da esse erro na hora de iniciar o geodata,
dai fiz um teste desativando o geodata, mas o erro continua..
queria ver se é só comigo, por que pode ser alguma coisa relacionado com a versão do windows, não sei
por que pelo que deu pra ver na imagem do
terry123456

 

ele conseguiu comprar, então pode ser que não seja um erro de java e sim alguma coisa com a versão do meu SO.

Compartilhar este post


Link para o post
Compartilhar em outros sites
set JAVA_OPTS=%JAVA_OPTS% -XX:PermSize=128m >> 1128

set JAVA_OPTS=%JAVA_OPTS% -XX:MaxPermSize=256m >> 1256


REM Ìèíèìóì è ìàêñèìóì âûäåëÿåìîé ïàìÿòè

REM Ìèíèìàëüíëå çíà÷åíèå äëÿ çàïóñêà ñ ãåîäàòîé: 1.5G

REM Ìèíèìàëüíîå çíà÷åíèå äëÿ çàáóñêà áåç ãåîäàòû: 1G

REM -Xms è -Xmx äîëæíû áûòü âñåãäà ðàâíû äðóã äðóãó.

set JAVA_OPTS=%JAVA_OPTS% -Xmn512m >> 1512

set JAVA_OPTS=%JAVA_OPTS% -Xms1024m >> 2024

set JAVA_OPTS=%JAVA_OPTS% -Xmx1024m >> 2024


as minhas configs estão assim, e vai de boas...

Compartilhar este post


Link para o post
Compartilhar em outros sites

então cara, tu consegue comprar de boa ?

vou tentar alterar dessa forma se mudar alguma coisa te aviso.


 

set JAVA_OPTS=%JAVA_OPTS% -XX:PermSize=128m >> 1128
set JAVA_OPTS=%JAVA_OPTS% -XX:MaxPermSize=256m >> 1256
REM Ìèíèìóì è ìàêñèìóì âûäåëÿåìîé ïàìÿòè
REM Ìèíèìàëüíëå çíà÷åíèå äëÿ çàïóñêà ñ ãåîäàòîé: 1.5G
REM Ìèíèìàëüíîå çíà÷åíèå äëÿ çàáóñêà áåç ãåîäàòû: 1G
REM -Xms è -Xmx äîëæíû áûòü âñåãäà ðàâíû äðóã äðóãó.
set JAVA_OPTS=%JAVA_OPTS% -Xmn512m >> 1512
set JAVA_OPTS=%JAVA_OPTS% -Xms1024m >> 2024
set JAVA_OPTS=%JAVA_OPTS% -Xmx1024m >> 2024
as minhas configs estão assim, e vai de boas...

 

 

 

 

Cara mudei deixei exatamente como o seu GS, mas deu a mesma coisa...

 

https://ap.imagensbrasil.org/image/Orlsy

 

olha ali na imagem pra ti ver, memoria usada 32% e livre 68 %...

 

esses erros são normais ? la em baixo diz (unknown source) normal isso?

Compartilhar este post


Link para o post
Compartilhar em outros sites

então cara, tu consegue comprar de boa ?

vou tentar alterar dessa forma se mudar alguma coisa te aviso.

 

 

 

Cara mudei deixei exatamente como o seu GS, mas deu a mesma coisa...

 

https://ap.imagensbrasil.org/image/Orlsy

 

olha ali na imagem pra ti ver, memoria usada 32% e livre 68 %...

 

esses erros são normais ? la em baixo diz (unknown source) normal isso?

testa com a compilada que tenho aqui

 

 

 

Se tiver como me upar a system que tá usando, teria como?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Dwbryel

to usando essa system que o tlutino postou, mas ela ta buggada, não aparece os itens as vezes... sei la ahsuauhsuah

http://www.l2jbrasil.com/index.php?/topic/118038-system-underground-en-protocolo-28-18052016/

com cliente americano atualizado dai...

 

(cara deu mesmo erro, com o compilado que tu postou)

se ta funcionando no teu pc, dai já nem imagino oque pode ser, porque outros servidores rodam normal no meu pc.

 

 

 

//Só pra constar, eu testei com esse cliente e com outro com protocolo 610... e tbm não vai..da o mesmo erro.

Editado por kronas

Compartilhar este post


Link para o post
Compartilhar em outros sites

Dwbryel

to usando essa system que o tlutino postou, mas ela ta buggada, não aparece os itens as vezes... sei la ahsuauhsuah

http://www.l2jbrasil.com/index.php?/topic/118038-system-underground-en-protocolo-28-18052016/

com cliente americano atualizado dai...

 

(cara deu mesmo erro, com o compilado que tu postou)

se ta funcionando no teu pc, dai já nem imagino oque pode ser, porque outros servidores rodam normal no meu pc.

 

 

 

//Só pra constar, eu testei com esse cliente e com outro com protocolo 610... e tbm não vai..da o mesmo erro.

estranho aqui vai de boas... todos da equipe aqui...

procuro a system do protocol 19...

Compartilhar este post


Link para o post
Compartilhar em outros sites

então procurei um monte tbm essa system e não encontrei. então brother oque eu vou te dizer, chato isso,

queria trabalhar em cima desse projeto, quando você compila aparece algum warning ? aqui aparecem 100 warning,

ja baixei a ultima versão do java JDK e JRE e tbm o ultimo eclipse, ja criei o PATH,JAVA e JAVA_HOME novamente

mesmo assim da os mesmo warning e e o mesmo erro, mas é estranho por que só ocorre com esse projeto, o mais estranho é só acontecer comigo...

acredito que talvez seja alguma coisa com o cliente talvez, alguma packed diferente, ja hora de gravar no inventario o item, o server pode não encontrar e dai travar.

 

vocês estão utilizando essa system do tlutino?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Galera para compilar de boa tem que config o BULD PATCH sobre comprar e da erro eu loguei com a system 28 que tem aqui n a atualizada !!

http://www.l2jbrasil.com/index.php?/topic/118038-system-underground-en-protocolo-28-18052016/

 

demonika

 

Ta afim de abrir uma svn é melhor dazer um downgrade de uma source do que arrumar essa. Quem quiser entrar nessa manda mp peço se isso n pode falar aqui montar uma equipe por gentileza tire o post.

Compartilhar este post


Link para o post
Compartilhar em outros sites

 

terry123456 é essa system que to usando e que ta dando o erro, tem mais gente com o mesmo problema, pensei que fosse algo no meu pc. pode explicar melhor como configurar o build patch?

Compartilhar este post


Link para o post
Compartilhar em outros sites



     


  • Quem Está Navegando

    Nenhum usuário registrado visualizando esta página.

×