Ir para conteúdo


[Tutorial] Adicionando Custom's no seu Servidor.


241 respostas neste tópico

#101    l2edit

l2edit
  • Muito Noob

  • 139 posts

Postado 11 novembro 2009 - 19:52

:wawa...aaa: to querendo uma resposta....sera que tem jeito de responder ai galera.....so falta a skillgrp

 


#102    EvertonxD

EvertonxD
  • ForeverAlone

  • 1 posts

Postado 16 novembro 2009 - 20:17

Ta dando erro aqui tbm =/
ja testei vario file edit mas naum quer abrir.
naum sei qual o problemas pois eu fiz tudo corretamente, so da erro na hora do file editm :dancecat: :wacko:

#103    Autobots

Autobots
  • ForeverAlone

  • 1 posts

Postado 17 novembro 2009 - 14:39

Ei Alguem Pode Me Ajudar Ta Dando O Mesmo Erro No FileEdit Quando Eu Vou Colocar O Set Sacrifice No Meu Server Sempre Quando Eu Vou Salvar No Desktop Da Erro Se Alguem Puder Me Ajudar Eu Agradeco Flw

#104    Guma

Guma
  • L2JBrasileiro

  • 5.477 posts

Postado 17 novembro 2009 - 17:18

veja c os itens q vcx tao querendo add e para a msm versao do cliente
e se tao deixando uma linha vaga no final e salvando em 413.
c der erro e pq o q vc ta tendando adiciona nao para o cliente q vc usa.

[img]https://www.ohloh.net/accounts/65499/widgets/account_tiny.gif[/img]

svn | timeline
activeMember.sendMessage("Quase tudo é possível quando se tem dedicação e habilidade. Grandes trabalhos são realizados não pela força, mas pela perseverança")


#105    int3rlude2

int3rlude2
  • ForeverAlone

  • 11 posts

Postado 18 novembro 2009 - 10:33

mano eu to fazendo tudo certinho adicionei o arkivo sql, colei a xml no local certo ,consegui add o itenname de boa
mas o problema e no weapongrp qdo eu vou "salvar como" da esse erro ai:
se alguem tiver uma luz so falta isso!
vlw obrig ta ai a imagen:

[img]http://img5.imageshack.us/img5/3863/apresentao1ao.jpg[/img]

#106    Edson Junior

Edson Junior
  • ForeverAlone

  • 18 posts

Postado 07 dezembro 2009 - 12:22

JA EU FIZ TUDO COLEI A XML NO LUGAR CERTO ADD O INTERNAMEGRP E O WEPONGRP DA TUDO CERTO AI QUANDO VOU PRO JOGO QUE COLOCO O ID DO ITEM NAO APARECE NADA PQ ?

#107    Kelvin

Kelvin

Postado 07 dezembro 2009 - 12:56

Colocou as texturas dentro da pasta systextures... e animações (se vinher) na pasta animations? Lembrou de executar a SQL?

#108    sassukexxt

sassukexxt
  • ForeverAlone

  • 1 posts

Postado 08 dezembro 2009 - 22:38

-----------------------------------------------------------------------
Programas Necessarios:
FileEdit: Download Aqui.
-----------------------------------------------------------------------

Em primeiro Lugar, escolha o Custom que você quer adicionar em seu Servidor. Clique aqui, e escolha o que você preferir.

Começando:

Como é um Tutorial, vou usar as

Por favor, acesse sua conta ou cadastre-se para ver este conteúdo oculto.

, e a versão do meu Servidor é Gracia Parte2, mas pode ser feito com outros Versões normalmente.

1.1 Faça o Download, extraia os Arquivos.

[img]http://img158.imageshack.us/img158/2853/foto1cf5.jpg[/img]

1.2 Abra o seu Navicat, e a table do seu Servidor, no meu caso é l2jdb.

[img]http://img144.imageshack.us/img144/6605/foto2vz1.jpg[/img]

1.3 Clique com o botão direito em cima ta table do seu servidor, no meu caso, à minha é l2jdb, e clique em Execute Batch File...

[img]http://img502.imageshack.us/img502/9710/foto3rx6.jpg[/img]

1.4 Clique nas ... (3 Bolinhas), e procure a SQL do Arquivo Custom que você baixou, e clique em Start.

[img]http://img88.imageshack.us/img88/5896/foto4pb3.jpg[/img]

1.5 Se tudo der certo, o Navicat conseguir carregar a SQL, vai aparecer essa mensagem.

[img]http://img441.imageshack.us/img441/8341/foto5on9.jpg[/img]

1.6 Todo Custom Item, precisar ter um Arquivo XML, pra o Servidor ler ele. (Onde fica os Status do Custom). No caso das Epic Weapons, tem que colar o Arquivo XML, na pasta ...\gameserver\data\stats\weapon.

[img]http://img185.imageshack.us/img185/9757/foto6xs9.jpg[/img]

Número 1: É a Pasta Weapon que eu citei acima. ...\gameserver\data\stats\weapon.
Número 2: É o Arquivo XML, que onde fica os Status das Weapons Epic.


Passo 2:

- Feito os Passos Acima, e tudo tiver dado certo, então vamos por as Weapons Epic, nos arquivos "itemname-e.dat" e "weapongrp.dat", como meu Servidor é Gracia, vou usar um File Edit Gracia, mas você poderá usar outros, que não haverá herros.

1.7 Com o File Edit aberto, abra o Arquivo, "itemname-e.dat", na pasta do Custom Item, é provável que tenha duas pastas.
Server = Onde fica os Arquivos pra Adicionar no Navicat(SQL), e os arquivos XML.
Client - Onde fica os Arquivos em Bloco de Notas, para poder adicionar nos Arquivos da System.

[img]http://img258.imageshack.us/img258/6086/foto7yy9.jpg[/img]

1.8 Como vamos Adicionar primeiro o itemname-e. Abra o itemname-e.txt, sempre comece a selecionar apartir de uma linha abaixo.

[img]http://img211.imageshack.us/img211/2210/foto8xy8.jpg[/img]

1.9 Copiado as linhas da foto acima, e com o File Edit aberto, abra-o itemname-e.dat, da pasta System, e cole-o na ultima linha.

[img]http://img255.imageshack.us/img255/12/foto9pi2.jpg[/img]

Perceba, que sempre tem que deixar uma linha por último.

2.0 Feito o passo de cima, clique no canto esquerdo, em Save and encrypt.
Atenção, no local para Salvar o arquivo, nunca Salve na mesma pasta que você abriu, ou sejá, se você abriu, o itemanem-e.dat, na pasta do seu Client L2, salve ele em outro Lugar, o mais recomendável, na Desktop.

[img]http://img104.imageshack.us/img104/9633/foto10tn1.jpg[/img]

Número 1: Lugar para Salvar o Arquivo, recomendável na Desktop.
Número 2: "Salvar como tipo:" sempre coloque Dat Files.
Número 3: Sempre Salve como 413.


2.1 Clique em [img]http://img442.imageshack.us/img442/5265/foto11oz6.jpg[/img] para Salvar, se nada aparecer, é que tudo deu certo. Então copie o arquivo que foi Salvo e cole na System, e o Custom que você escolher já vai estar Adicionado.

2.2 Isso vale também, para os arquivos, "weapongrp.dat", "armorgrp.dat", entre outros.

Creditos: SheZ ® AllRights Reserved.





Proibida a reprodução mesmo que em partes desse tutorial sem a publicação dos devidos créditos de criação

Por favor, acesse sua conta ou cadastre-se para ver este conteúdo oculto.



#109    Vitorscracho

Vitorscracho
  • Muito Noob

  • 61 posts

Postado 16 dezembro 2009 - 18:07

o meu tb ta com esse erro eu add no itenname-e foi de boa agora no weapon grp e armor grp fica com o mesmo erro do cara ae do print
ja abaixei os ids todos menores possiveis ja executei o sql os arquivo xml tudo de boa so essa parada ae que nao estou coneguino fazer
se algume puder ajudar fico esperando Neh!

#110    Vitorscracho

Vitorscracho
  • Muito Noob

  • 61 posts

Postado 16 dezembro 2009 - 18:08

o meu tb ta com esse erro eu add no itenname-e foi de boa agora no weapon grp e armor grp fica com o mesmo erro do cara ae do print
ja abaixei os ids todos menores possiveis ja executei o sql os arquivo xml tudo de boa so essa parada ae que nao estou coneguino fazer
se algume puder ajudar fico esperando Neh!

#111    DanielSantos

DanielSantos
  • WhereHave(Life)ThereIs(Hope)

  • 3.685 posts

Postado 19 dezembro 2009 - 16:53

faz manualmente pelo bloco de notas ;)

Obrigado vira em Breve

azc67n.png

 Clique em Curti para Motivar Muitos outros a tbm Fazer o Mesmo pois assim Motiva a Responder  :onda:


#112    liberty

liberty
  • ForeverAlone

  • 47 posts

Postado 23 dezembro 2009 - 15:54

MANOS EU FUI ADD AS ARMAS NO MEU SERVE. EU ADD NA ITEMNAME-E MAIS NA HORA DE EU ADD OS NEGOCIOS NA WEAPONGRP DEU ERRO ESSE AKI O
" CANNOT OPEN FILE C:/ ...WEAPONGRP . O SYSTEMA NAO PODE ENCONTRAR O ARQUIVO ESPECIFICADO. OQ EU FACO???

#113    Lord-Of-Angel

Lord-Of-Angel
  • Apedeuta

  • 1.220 posts

Postado 24 dezembro 2009 - 12:13

IXI QUANDO DA ESSE ERRO NAO TEM CONCERTO É PQ AS LINHA DO WEAPONGRP DA ARMA NAO BATE COM A TABELA DO CLIENTE O JEITO É VC DESISTI OU TENTA ALINHA TODAS LINHAS NA TABELA Q É UM SACRIFICIO


[img]http://img27.imageshack.us/img27/926/kb24isonfirewj1.jpg[/img]


#114    Nichtcrawler

Nichtcrawler
  • Muito Noob

  • 83 posts

Postado 02 janeiro 2010 - 23:55

^_^ isso e moleza

#115    Just4You

Just4You
  • Apedeuta

  • 1.411 posts

Postado 07 janeiro 2010 - 10:56

Aew pessoal...

alguem sabe como tirar o "<releated to quest> (nome da quest)"?

se alguem souber, por favor...
me fala!!

obrigado!
A Vida é uma eterna lição...
Estamos sempre aprendendo...

#116    maxloquin

maxloquin
  • ForeverAlone

  • 28 posts

Postado 21 janeiro 2010 - 07:44

olha!
tenho uma duvida aki!!
tipow!
coloquei alguns custons... alguns funfaram outros naum... tipo
fiz tudo q ta ai no tuto.. e tud deu certo. mas na hora de criar o item ele diz q o item foi criado mas nao aparece no meu inventario...
como resolvo????

#117    gabga

gabga
  • ForeverAlone

  • 9 posts

Postado 13 fevereiro 2010 - 09:19

Estou com umk problema, que todo custom que baixei nao veio com XML, poderia ser com outra arquivo?

#118    Lord-Of-Angel

Lord-Of-Angel
  • Apedeuta

  • 1.220 posts

Postado 19 fevereiro 2010 - 14:03

Aew pessoal...

alguem sabe como tirar o "<releated to quest> (nome da quest)"?

se alguem souber, por favor...
me fala!!

obrigado!


N TEM ND A VER COM ESSE TUTORIAL TENTE FAZER ESSA PERGUNTA AQUI!

http://www.l2jbrasil...hp?showforum=18


olha!
tenho uma duvida aki!!
tipow!
coloquei alguns custons... alguns funfaram outros naum... tipo
fiz tudo q ta ai no tuto.. e tud deu certo. mas na hora de criar o item ele diz q o item foi criado mas nao aparece no meu inventario...
como resolvo????


é pq vc n adcinou o armorgrp ou weapongrp correcto ou pode ter dado erro na hora de adcionar no navicat ou vc nao adicionou os html devidamente vc tem que comfirmar tudo issu!



Estou com umk problema, que todo custom que baixei nao veio com XML, poderia ser com outra arquivo?


quais customs vc baixou e que xml vc ta referindo das multisell?


[img]http://img27.imageshack.us/img27/926/kb24isonfirewj1.jpg[/img]


#119    Crysisz

Crysisz
  • ForeverAlone

  • 4 posts

Postado 22 fevereiro 2010 - 00:36

Bem tava fazendo um npc shop como um tuto e fiz tudo certo pus as xml e as html no sitio certo executei o sql e deu isto "

Por favor, acesse sua conta ou cadastre-se para ver este conteúdo oculto.

" isso diz success mas na DB nao aparece e no jogo do spawn tambem nao o que sera?

#120    CoelhOeLemeZ

CoelhOeLemeZ
  • ForeverAlone

  • 39 posts

Postado 02 março 2010 - 13:39


Opa, blz??
olha soh, eu fiz uma vez e deu certo... porém
quando eu fui fazer na segunda deu um erro no mesmo file edit
q eu utilizei da primeira vez...

#erro abaixo

Por favor, acesse sua conta ou cadastre-se para ver este conteúdo oculto.


Por favor, acesse sua conta ou cadastre-se para ver este conteúdo oculto.



oq eu faço pra não dar mais este erro???

Desde jah agradeço...
vlw teh mais!!!
abraço!
----edit---
pra add quote =)

Editado por CoelhOeLemeZ, 02 março 2010 - 13:42.





0 usuário(s) está(ão) lendo este tópico

0 membros, 0 visitantes, 0 usuários anônimos

© L2jBrasil - Todos os direitos reservados
NCsoft©, the interlocking NC logo, Lineage© II, and all associated logos and designs are trademarks or registered trademarks or service marks of NCsoft Corp.
All rights reserved and other trademarks are the property of their respective owners.