Ir para conteúdo
  • Anúncios

    • AiroN

      Anuncie no L2JBrasil

      Deseja anunciar aqui no fórum, no Top L2JBrasil ou em nossa página no Facebook? Confira: www.l2jbrasil.com/anunciar
    • Grundor

      Método de login alterado   08-10-2017

      Com a atualização do fórum para versão  IPB 4.2 não é mais possível fazer login usando username, ao invés disso você deve usar e-mail ou seu Display Name (nome como é exibido no forum).      
    • AiroN

      Tenha seu clube formalmente no L2JBrasil!   18-10-2017

      Você tem amigos que estão sempre juntos contigo na alegria e na tristeza, na saúde e na doença, em todos os desenvolvimentos de suas vida, no pvp, nas quests? rsrs   Monte seu clube formalmente na L2J Brasil!
      Criar um clube é muito fácil, basta você entrar nesse tópico e se interar do assunto:    Dominem o mundo!


      Atenciosamente, Natã Felipe
      Administração L2jBrasil.
Kelvin

[Tutorial] Criando Servidor de Lineage 2.

Recommended Posts

Deleta o localhost e cria denovo mas quando for criar, crie ele sem senha.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Vlwwwwwwwwwwwwwwwwwww aeeeeeeeeeeeeeewwwwwwwwwwwwwww maaaaaaaaaaaaaaaaaan

vlw msm

eu tava me matanu aki

mas e que antes eu criei um mysql com senha

ai quando eu deixava sem senha ele naum aceitava

^^

vlw ai.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Man olha aew

eu ligo o server direito tudo certo ai quando eu coloco para eu jogar ai fika la parado . . .

carregando ai depois de um tempao <_<

 

Eu faco oq ?.?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Não entendi o servidor liga normal? O jogo abre de boa?

Se for isso só digitar um login e uma senha que entra no jogo..

Compartilhar este post


Link para o post
Compartilhar em outros sites

nao tipo u jogo naum abre

tipo vc naum clica para abrir u jogo

entao aparece um negoco carrengando para depois abrir a tela para vc coloca o login e a senha

e ai que trava

sera que so pega se for com us arquivos interlude?

eu colocquei a system no kamael xD

sera que e por isso?

Compartilhar este post


Link para o post
Compartilhar em outros sites

kelvin tava fazendo ums teste com ums amigos meu o serve so ta indo ate a hora de escolher os mundos dai nao sai mais do lugar fica parado pode me dizer o que e isso?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Ola pessoal,

 

Muito interessante o forum, eu havia criado um server seguindo um desses tutorias do kelvin há muito tempo e tinha dado tudo certo. Fui fazer novamente e tive um problema ao editar o l2.ini.

 

Baixei o arquivo L2JFree Final PreConfigurado por Kelvin.rar (da pasta gracia do 4shrared)

Instalei o CT2 Gracia Part I mas não consigo editar de forma alguma o l2.ini.

 

O arquivo Editor L2.ini.exe não executa no meu micro. Clico 2 vezes nele (dentro da system) e nada.

 

Ja tentei modo de compatibilidade e ja tentei usar o FileEdit, sem sucesso. O start login / game server estão rodando 100%. Só me falta editar o l2.ini.

 

Aguardo e obrigado.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Kelvin eu fiz tudo que está escrito só que na hora que executei o Edito l2.ini num abriu falou que num tinha l2.text dai copiei e colei o do 'LineBras.org' (server que eu jogo) agora não está abrindo o l2.exe da pasta system. <_<

 

Quequeu faço?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Primeiro qual versão do L2 vc quer editar?

Vai na seção servidores e baixa um servidor e um patch, eles já vem com o IP configurado para você logar na maquina que está o servidor.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Eu segui o video e o tuto, na hora de de cria o char ADM ja com o lineage aberto isso (no video nos 14,15min por ai) utilizei o Game Guard Resolve mas não tinha nenhum arquivo da 1ª vez dai foi direto sem precisar sibstituir nada, e mesmo assim ta dando o erro, fala que achou um programa hacker e talz dai dou 'Ok' e fecha o lineage sozinho. :/

 

Alguém ai poderia ajudar?

Compartilhar este post


Link para o post
Compartilhar em outros sites

É problema na system, baixa um patch lá na seção servidor...

Compartilhar este post


Link para o post
Compartilhar em outros sites

Kelvin ou alguém ai que saiba, NÃO ta vindo os buffs do npc, escreve la "você ja pode sentir o efeito de blablabla" mais num fica o buff, tipo ele num aparece na barra.

 

Ajuda ai, Obrigado.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Mauricio... é por que tu ta com char GM digita //invul para sair a invunerabilidade que os buff no teu char pega de boa.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá Kelvin..

 

Cara, obrigado pelos tutoriais. O Pessoal aqui da lan vivia pedindo para abrir logo um server (Em vista que muiita gente aqui joga L2 Revo), então decidi criar um.

 

Estou a uma semana, e até agora está tudo tranquilo, estou pacientemente edidando todos NPCs das principais cidades, Buffers, Tattoos, etc.. Meu problema aqui está sendo apenas colocar o server rodando OnLine.. agente (eu e mais um amigo) ficamos até as 4:00 da manhã tentando resolver isso e nada..

 

Então, dessa não teve jeito. Preciso mesmo de sua ajuda.. veja o caso aqui, e ajude se poder:

 

PortasModenabertas.jpg

Portas do Modem (Roteador) abertas - Para Login e Game Servers

 

erroip.jpg

Modo que está configurado o Login Server

 

ErroCliente.jpg

Erro ao abrir o Login Server.

 

Bom, é isso.. vamos por partes, uma vez deixando a conexão do Login, passamos para o GameServer..

 

Flw cara, obrigado!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Opa, atualizando aqui.. esse é o jeito "máximo" que eu to conseguindo chegar:

 

portasatual.jpg

Portas...

 

conectcombug.jpg

Login server e Game server conectados

 

Ok... mas o problema, é que: Eu logo normalmente, mas.. nao passa daqui:

 

npassadaki.jpg

 

Como disse, ele chega a logar, mas depois nao entra.

 

Oque faço Kelvin, tem uma solução ae? Será que com o No-IP ele passa a conectar heim... ? vlw

Compartilhar este post


Link para o post
Compartilhar em outros sites

Os Ip's Do server estão certos? o meu server ta acontecendo isso tbm fui ver era os Ips q estavam erados!:)

Compartilhar este post


Link para o post
Compartilhar em outros sites

-Off-, você poderia postar pra mim o exemplo de IPs que você está usando? Não sei se estou fazendo correto.. olha como está aqui:

 

LOGIN SERVER:

 

# ================================================================

# General login server setting !!! REQUIRED to configure to everyone !!!

# ================================================================

 

# Bind ip of the loginserver, use 0.0.0.0 to bind on all available IPs

LoginServerHostname=127.0.0.1

LoginServerPort=2106

GMMinLevel=100

 

# The port, ip on which login will listen for GameServers

LoginHostname=192.168.254.1 O QUE COLOCAR AQUI? O IP DA MINHA CONEXÃO EXTERNA? Esse é de rede interna..

LoginPort=9014

 

# If set to true any GameServer can register on your login's free slots

AcceptNewGameServer = False

...

 

SERVER Configs

 

# ================================================================

# General server setting !!! REQUIRED to configure to everyone !!!

# ================================================================

 

# ATENÇÃO! ESSE SERVER ESTÁ CONFIGURADO PARA RODAR SOMENTE NO SEU COMPUTADOR SIGA ALGUMAS DAS INSTRUÇÕES ABAIXO PARA RODA EM LAN OU ONLINE.

# Bind ip of the gameserver, use 0.0.0.0 to bind on all available IPs

GameserverHostname=0.0.0.0

GameserverPort=7777

 

# This is transmitted to the clients connecting from an external network, so it has to be a public IP or resolvable hostname

# ATENÇÃO: Coloque seu NO-IP ou DDNS aqui em ExternalHostname= se você quiser jogar online.

ExternalHostname=189.26.211.176 ESTE É O IP DE MINHA CONEXÃO COM A INTERNET (EXTERNO)

# This is transmitted to the client from the same network, so it has to be a local IP or resolvable hostname

# ATENÇÃO AQUI ESTÁ CONFIGURADO PARA VOCÊ JOGAR OFFLINE, SE QUISER JOGAR EM LAN COLOQUE SEU IP INTERNO VA EM INICAR>EXECUTAR DIGITE CMD QUANDO ABRIR DIGITE IPCONFIG E VEJA SEU ENDEREÇO E PONHA AQUI EM BAIXO!

InternalHostname=127.0.0.1

# Define internal networks (10.0.0.0/8,192.168.0.0/16 is default internal networks)

InternalNetworks=

# Define optional networks and router IPs

# IP (200.100.200.100) or fully qualified domain name

# (google.com) that resolves to an IP (use ping to determine if a domain resolves).

# Format: ip,net/mask;ip,net/mask,net/mask

# (mask 192.168.0.0/16 or 192.168.0.0/255.255.0.0 would be 192.168.*.*)

# Note: keep InternalNetworks and OptionalNetworks blank for compatibility with older login server

OptionalNetworks=

 

# The Loginserver host and port

LoginPort=9014

LoginHost=192.168.254.1 IP DA REDE INTERNA

 

# This is the server id that the gameserver will request (i.e. 1 is Bartz)

RequestServerID = 1

# If set to true, the login will give an other id to the server if the requested id is allready reserved

AcceptAlternateID = True

...

 

 

Bom, tá ae em negrito, os IPs que coloquei aqui. Desta forma, consegui logar, mas não passa da tela de conexão com o servidor.

 

Obrigado pela atenção ae, vlw!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Gente pra quem não passa da tela do login é facil.

Vocês estão na maquina que o servidor está rodando então o modem não influencia... é só deixar os Ips do jeito que estão, para logar no PC que esta a maquina é o ip interno no casó o localhost que é 127.0.0.1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Kelvin, aqui no meu caso eu já estava passando para a parte 2, digamos... ou seja, tentando conectar ao servidor por uma conta em outro computador, bairro, etc.. pela net mesmo.

 

Mas já consegui aqui e agora o server tá blz... e foi pura burrada o que eu estava fazendo, e pior... mais burrada ainda ter vindo postar direto aqui sem ter lido 1 tópico que está na primeira página de tutoriais.

 

Tutorial para colocar server de lineage on com sistema DDNS http://www.l2jbrasil.com/index.php?showtopic=71

Tutorial elaborado pelo user Grundor..

 

Segui o tutorial mais algumas modificações que tive de fazer aqui pra o server reconhecer o client.. apenas isso diferente

 

Só não havia entrado no tópico pq eu não tinha nem ideia do que era DDNS... agora eu sô fã do programinha rs

 

 

Bom, vlw ae Kelvin, os arquivos que vc liberou pra galera me ajudou muito aqui. Só falta terminar de editar os npcs aqui que já está quase pronto, e mais algumas customizações que colocarei depois.. mas, considerando o estado atual da coisa, já dá para o pessoal logar e divertir..

 

Ontem eu e mais 3 amigos do bairro logamos, e ficamo a noite toda zuando no server batendo screen-shots e tirando PVPs hehehehe

 

 

Obrigado ae, vlw mesmo. :D

Compartilhar este post


Link para o post
Compartilhar em outros sites

oi beleza, eu criei um server aki no meu pc, esse ai q ta no post, do kelvin, fiz como manda e unfo legal, soq o cliente q eu uso ta faltando arquivos, ... texturas e tal ... queria saber aonde pegar as texturas , ou o cliente ou o pacth desse db q o kelvin fez.

 

e pq meu cliente falta arquivo.

 

e uma outra duvida . meu moden e um broadband / rca da net rio (niteroi / rj)

e como faço pra liberar o parta de le a 7777 como vc diz ai ......... no tutu...

 

vlw.. [email protected]

meu msn

Compartilhar este post


Link para o post
Compartilhar em outros sites

Kelvin tô com uma duvida .. o Client de L2 que eu tenho aki no meu pc é Gracia CT2 Final ..

se eu criar outra system com os dados do Interlude vai dar critical error por causa dos systextures ?

 

;]

Compartilhar este post


Link para o post
Compartilhar em outros sites
Kelvin tô com uma duvida .. o Client de L2 que eu tenho aki no meu pc é Gracia CT2 Final ..

se eu criar outra system com os dados do Interlude vai dar critical error por causa dos systextures ?

 

;]

 

Ele não ira dar erro nunca por causa de systexure, mas ele obviamente ira dar erro no seu .DAT que está as informações do interlude, porque as linhas dos .dat do interlude não funciona a partir do kamael em diante.

Compartilhar este post


Link para o post
Compartilhar em outros sites

por favor me ajudem .. esta dando erro..

aparece essa mensagem no start game server //

Dawn ! registeration failed : reason : wrong hexid

 

pq isso? me ajudem ae por favor to quase .. ;)

Compartilhar este post


Link para o post
Compartilhar em outros sites






Anuncie em nossa página no Facebook!
Confira o regulamento.
Contate-nos através do e-mail: [email protected] para mais informações.


  • Quem Está Navegando

    Nenhum usuário registrado visualizando esta página.

×