Jump to content

Kryvios

Membro
  • Content Count

    9
  • Joined

  • Last visited

Community Reputation

0 Normal

About Kryvios

  • Rank
    ForeverAlone
  1. Ok, mas as pessoas tem de baixar o aplicativo pra entrar no servidor? Isso seria um problema... Vou logo alugar um dedicado, rs Vocês podem me indicar uns bons?
  2. Eu consegui logar nos 2 PC's usando a mesma internet(progresso, porque anteriormente nem assim deu certo) mas apenas com o IP 10.0.0.103, o local, quando eu mudo pra internet roteada pelo celular não loga, e quando eu coloco o IP da minha máquina direto 45.233.11.195, mesmo fora do No-IP não dá certo, o que pode estar ocorrendo?
  3. Eu achei a opção de colocar um IP estático, vamos ver se funciona Aí não dependo do No-IP... OBS: adicionei o meu IP no DMZ também, desculpe a ignorância nessa parte eu não tenho muito conhecimento, agora vai kkkkk Obrigado irmão
  4. As portas já estão abertas no Firewall, 9014, 3106, 2106 e 7777 como TCP/UDP No DMZ coloco qual IP? De último caso pode ser isso mesmo, entrarei em contato sim
  5. Novamente, com o servidor ligado fiz o teste das portas, e deu erro, então quase certeza que o erro está no roteador, eu fiz algo errado... Testei a 3306, 2106 e 7777 e todas deram Connection refused.
  6. Bom, fiz tudo... Mudei o endereço na L2.ini pra l2str.servegame.com, mudei o ipconfig.xml, tá ligado no No-IP, mas agora o erro é diferente... Não aparece aquela mensagem, porém não loga, será que são as portas? Está anexado aqui a seção das portas do meu roteador: Esse roteador é tão moderno que eu posso vincular com o NoIP, pena que eu não entendo muito disso... Aqui vai um print da execução: Ah, e tem umas outras opções no final sobre o Roteador, eu devo mudar algo? OBS: tá até logando com a configuração do ipconfig.xml alterada, mas como eu disse... É só mudar o L2.ini pro endereço l2str.servegame.com que o bichinho não loga... E sobre isso, eu quero deixar online pra qualquer um acessar, o que eu devo mudar? Meu servidor está nesse PC, como eu disse, e estou tentando logar em outro EDIT: presumi que o erro seria estar 10.0.0.105 ao invés de 10.0.0.103, já editei, porém o erro continua... Em ambos os PC's que testei.
  7. É aí que eu vejo os subnets? Essa configuração veio por padrão do L2jSunrise, interfere muito no funcionamento? Eu edito ou apago as linhas? Coloco o mesmo do External(l2str.ddns.net) ou só 127.0.0.1? Ah, e eu tenho um servegame.com também, mas ainda não o testei, não imaginava que o erro poderia estar aí, por algum descuido meu não tinha visto aquele tópico, quando configurei o servegame.com também apareceu todas aquelas opções a mais pra eu registrar, vamos ver se funciona... logo após replico aqui. Sim, eu usei outro computador roteando o 4G do meu celular pra testar o login em IP diferente(testado pelo MeuIP), como se fosse um jogador normal tentando jogar com a system baixada em seu computador, e deu aquele erro. EDIT: eu tinha esquecido de falar, quando mudei o IP no ipconfig.xml para o l2str.ddns.net, consegui logar sim, apareceu que estava ON por esse IP no loginserver.exe(se quiser mando um print) no PC HOST consegui logar, porém sem editar o L2.ini da system, o que não adianta em nada... É só editar que dá erro também logando pelo PC HOST To testando o servegame.com, em menos de 1h respondo novamente dizendo se funcionou ou não, muito obrigado por enquanto irmãozin!
  8. Boa tarde galera da L2jBrasil, recentemente eu consegui a rev do L2jSunrise, configurei tudo certinho, ta rodando localmente no meu computador, não deu erro em nada, nada mesmo! Editei todos NPC's sem dor de cabeça, ficou tudo do jeito que eu queria, pré-pronto pra deixar online, e aí que está o problema... Eu já baixei o No-IP, e pelo que sei está configurado certo, como Host, mas como alguns devem saber na rev do L2jSunrise o External e o Internal não está no loginserver.ini, parece que está tudo em um só arquivo, este aqui: ipconfig.xml, com os seguintes códigos: <?xml version="1.0" encoding="UTF-8"?> <!-- Note: If file is named "ipconfig.xml" this data will be used as network configuration, otherwise server will configure it automatically! --> <!-- Externalhost here (Internet IP) or Localhost IP for local test --> <gameserver address="l2str.ddns.net" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="./ipconfig.xsd"> <!-- Localhost here --> <define subnet="127.0.0.0/8" address="127.0.0.1" /> <!-- Internalhosts here (LANs IPs) --> <define subnet="10.0.0.0/8" address="10.0.0.0" /> <define subnet="172.16.0.0/19" address="172.16.0.0" /> <define subnet="192.168.0.0/16" address="192.168.0.0" /> </gameserver> O l2str.ddns.net foi a host escolhida, eu adicionei no L2.ini, salvei na system, ok... Não consigo logar, continua rodando no MEU COMPUTADOR que está HOSTEADO só quando o IP External está 127.0.0.1, aí eu fui transferir a System para meu outro computador, roteando a internet do meu celular pra ser um IP diferente, e quando vou logar aparece "Can not resolve host name", como se o IP não estivesse funcionando. Gostaria de saber se na rev do L2jSunrise tem algo específico que eu deva mudar, algum arquivo a mais que eu não sei... já testei quase de tudo e ainda não deu certo. E eu tenho mais de uma dúvida, além dessa, porque pelo que notei o problema pode estar fora dos arquivos da L2jSunrise também, como no: 1° Navicat... Eu continuo como "Localhost" no usuário ou devo mudar algo? OBS: eu tentei mudar o nome de "Localhost" para "l2str.ddns.net" e deu erro pra abrir, eu tenho que mudar algo no MySQL ou no Navicat? Mensagem de erro do Navicat: "2003 - Can't connect to MySQL Server on 'l2str.ddns.net' (10061)" Ou quando vou editar a database do MySQL dentro do '"Localhost" aberto, tem o "proxies_priv", "server", "host", eu devo mudar algo aí? 2° Ou também no L2Editor que eu tenho pra descriptografar e salvar criptografado, está da seguinte maneira: [URL] Protocol=unreal ProtocolDescription=Unreal Protocol Name=Player Map=Index.unr LocalMap=Entry.unr Host= Portal= MapExt=unr EXEName=l2.exe SaveExt=usa Port=7777 Class=LineageWarrior.MFighter ServerAddr=l2str.ddns.net IsL2NetLogin=True IsL2Console=True IsL2Seamless=True IsL2Projector=True ISL2Mark=2 ForceAspectRatio=False AspectRatio=1.334 IsDefaultShaodw=False IsUnderWaterEffect=False IsUseCommand=True L2VersionCheck=false IsL2MemLog=False L2ThreadFilter=1 L2TestServer=false EnablePurgeLevel=True SharedSky=True L2MaxPawnResourceLoad=1.0 L2UseKeyCrypt=true L2UseReplayManager=true EnableSecondWindow=true IsUseXMLUI=True L2ShaderPath=..\system\ UseNewPetition=false L2HomeURL=http://www.lineage2.com/ CmdLineLogin=false ExternalLogin=false UseAuthUserData=true NOGG_Auth=true UseSecondaryAuth=false (Mas acho difícil estar algo errado aqui, porque quando salvei da maneira errada pelo L2 File Editor o Lineage 2 nem abriu). Pode ser a porta aberta? Eu devo/posso mudar a porta 7777? No Login Server Console, a última mensagem que aparece é que o Servidor está LIGADO no IP l2str.ddns.net/0.0.0.0/0 Então, espero que tenham entendido minha(s) dúvida(s), eu gostaria de encontrar o problema aí... E se nada resolver, tem como deixar no formato das revs normais do L2J? Com o External e o Internal. Desde já, obrigado a todos!
×
×
  • Create New...