Jump to content
  • 0
clebinho20

L2JNetwork erro ao inicializar GameServer

Question

8 answers to this question

Recommended Posts

  • 0
2 horas atrás, clebinho20 disse:

Pessoal estou com um erro chato demais ! Não consigo resolver e já procurei no fórum e não achei também 😂 Segue abaixo o print 

http://uploaddeimagens.com.br/imagens/sem_titulo-png-7a6817f2-9353-4222-89ea-d555ffa27933

Erro na conexão com a database brother. Sugiro ir nas configs, configurar o nome da db padrão, colocar senha lá se houver na db do mysql e configurar certo isso que dará boa! 

  • Like 1

Possui alguma dúvida em relação à configurações comuns de servidores de Lineage II? Consulte nossa área de Principais Dúvidas Resolvidas.

 

Atenção: Eu não dou suporte por MP, nem por nenhum meio de contato fora do L2J Brasil. Caso insista, será bloqueado e excluído.

 

Share this post


Link to post
Share on other sites
  • 0
12 minutos atrás, Nattan Felipe disse:

Erro na conexão com a database brother. Sugiro ir nas configs, configurar o nome da db padrão, colocar senha lá se houver na db do mysql e configurar certo isso que dará boa! 

Eu consegui arrumar etc, porem agora quero abrir para meus amigos entrarem no meu server e eu também conseguir entrar, Não estou conseguindo acertar a configuração.

Abaixo o gameserver

Citar

# ================================================================
#                          Gameserver setting
# ================================================================

# This is transmitted to the clients, so it has to be an IP or resolvable hostname. If this ip is resolvable by Login just leave *
Hostname = l2styller.ddns.net

# Bind ip of the gameserver, use * to bind on all available IPs.
GameserverHostname = 127.0.0.1
GameserverPort = 7777

# The Loginserver host and port.
LoginHost = 127.0.0.1
LoginPort = 9014

# This is the server id that the gameserver will request.
RequestServerID = 1

# If set to true, the login will give an other id to the server (if the requested id is already reserved).
AcceptAlternateID = True

#

e Abaixo o LoginServer
 

Citar

#=============================================================
#                         Loginserver
#=============================================================

# This is transmitted to the clients, so it has to be an IP or resolvable hostname
Hostname = l2styller.ddns.net

# Bind ip of the LoginServer, use * to bind on all available IPs
LoginserverHostname = 127.0.0.1
LoginserverPort = 2106

# The Loginserver host and port.
LoginHostname = 127.0.0.1
LoginPort = 9014

# How many times you can provide an invalid account/pass before the IP gets banned
LoginTryBeforeBan = 5

# Time you won't be able to login back again after LoginTryBeforeBan tries to login. Provide a value in seconds. Default 10min. (600)
LoginBlockAfterBan = 600

# If set to true, any GameServer can register on your login's free slots
AcceptNewGameServer = False

# If false, the licence (after the login) will not be shown. Default : true.
ShowLicence = True

#=============================================================

 

Edited by clebinho20

Share this post


Link to post
Share on other sites
  • 0

fique tranquilo você está ligando de maneira certa mais essa aCis network não vai deixar você logar usando localhost para seus amigos. junta vocês todos e aluga um vps de no minimo 4gb de memoria que consegue ate roda um beta nele


XXsPI3c.gif

Share this post


Link to post
Share on other sites
  • 0

As configurações todas estão certas ? onde ta l2styller seria onde eu colocaria o ip da vps, tanto como no l2.ini ? Por que eu estou tentando colocar por no-ip e não localhost, localhost seria se eles estivessem na minha rede interna também né ? 

Se for via hamachi eu conseguiria abrir em localhost?

Edited by clebinho20

Share this post


Link to post
Share on other sites
  • 0

@clebinho20 seja bem-vindo a comunidade L2jBrasil, 

Nós temos algumas regras e padrões para postagem e você infringiu algum desses padrões.

 

Esse tópico é uma dúvida por esse motivo está sendo movido para área de dúvidas e teve seu conteúdo editado pela moderação.

 

Em consideração à seu primeiro conteúdo vou estar respondendo, mas tópicos assim de membros com mais de 10 pontos de conteúdo são descartados sem aviso prévio.

 

Resposta:

 

O motivo do erro está debaixo do nariz de vocês, 

yFwKZDz.png

O que vocês entendem por "Unknown database 'rev31'" ?

Justamente ao pé da letra, o banco de dados não foi encontrado, isso significa que:

  • A conexão está ok, ela foi executada (pelo menos esse é o procedimento padrão em todas as conexões de banco de dados, agora se o l2jnetworks faz diferente ai complica)
  • Ao tentar selecionar o banco de dados de operação, que deve estar na config como "rev31", a base de dados não foi localizada.

Minha sugestão para resolver esse erro é refazer os passos de instalação conforme o  fornecedor da rev, após executar todos os passos você deve ser capaz de inicializar o gameserver.

  • Like 1

EJoOSOj.gif

Sua pergunta foi respondida? Certifique-se de marcar a resposta como a solução aceita.
Se existe mais de uma resposta, utilize o "vote up" para destacá-la.
Se você achar uma resposta útil, diga obrigado clicando no botão "Gostei".

Share this post


Link to post
Share on other sites
  • 0
6 minutos atrás, Grundor disse:

Isto é uma dúvida por esse motivo está sendo movido para área de dúvidas.

 

Caso necessário faça as edições para adequar às exigências.

Obrigado.

Share this post


Link to post
Share on other sites
  • 0

Caso tenha dúvida sobre como proceder sugiro a leitura dos seguintes tópicos:

 

 

 

EDIT:

Respondi sua questão.

  • Like 1

EJoOSOj.gif

Sua pergunta foi respondida? Certifique-se de marcar a resposta como a solução aceita.
Se existe mais de uma resposta, utilize o "vote up" para destacá-la.
Se você achar uma resposta útil, diga obrigado clicando no botão "Gostei".

Share this post


Link to post
Share on other sites
  • 0
3 horas atrás, Grundor disse:

Caso tenha dúvida sobre como proceder sugiro a leitura dos seguintes tópicos:

 

 

 

EDIT:

Respondi sua questão.

Sim, eu já tinha resolvido sobre isso. Porem estou usando esse tópico para fazer outra pergunta. Eu já consegui fazer meus amigos entrarem usando o no-ip, porem agora eu não consigo logar mesmo colocando no l2.ini 127.0.0.1 , eu logo e fica na hora de escolher o servidor e não sai disso.

Edited by clebinho20

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...




     



×
×
  • Create New...