Ir para conteúdo
  • Anúncios

    • AiroN

      Anuncie no L2JBrasil

      Deseja anunciar aqui no fórum, no Top L2JBrasil ou em nossa página no Facebook? Confira: www.l2jbrasil.com/anunciar
    • Grundor

      Método de login alterado   08-10-2017

      Com a atualização do fórum para versão  IPB 4.2 não é mais possível fazer login usando username, ao invés disso você deve usar e-mail ou seu Display Name (nome como é exibido no forum).      
    • AiroN

      Tenha seu clube formalmente no L2JBrasil!   18-10-2017

      Você tem amigos que estão sempre juntos contigo na alegria e na tristeza, na saúde e na doença, em todos os desenvolvimentos de suas vida, no pvp, nas quests? rsrs   Monte seu clube formalmente na L2J Brasil!
      Criar um clube é muito fácil, basta você entrar nesse tópico e se interar do assunto:    Dominem o mundo!


      Atenciosamente,
      Administração L2jBrasil.
Entre para seguir isso  
ylei

Site L2 Aukmenom Completo

Posts recomendados

Bom meu amigo Ylei sai da ''porcaria'' do easyphp agora tou usando Xampp1.7.2 tudo funcionando perfeitamente porem

o sistema de cadastro ainda não esta funcionando...

Vou fazer as modificações conforme o seu ultimo post e postar os resultados...

 

 

Tentei das duas Formas e nada ainda.... Sem cadastro pelo site =/

Editado por Allisson Mateus

Compartilhar este post


Link para o post
Compartilhar em outros sites
0Radamanthys0 > tente subistituir ( ereg ) por ( preg_match ) e veja se funciona.

if(ereg("^([a-zA-Z0-9_-])*$", $_POST['account']) && ereg("^([a-zA-Z0-9_-])*$", $_POST['password']) && ereg("^([a-zA-Z0-9_-])*$", $_POST['password2']))

por

if(preg_match("/^([a-zA-Z0-9_-])*$/", $_POST['account']) && preg_match("/^([a-zA-Z0-9_-])*$/", $_POST['password']) && preg_match("/^([a-zA-Z0-9_-])*$/", $_POST['password2']))

 

Funciona haha esta vivo.

aqui funcionou no firefox, chrome, opera e IE(ca).

Ylei infelizmente não obtive sucesso, você poderia mim informa qual programa você usa.

Eu uso Wamp server 2.0 e o PHP Editor

Compartilhar este post


Link para o post
Compartilhar em outros sites

Tb estou com o mesmo problema do cadastro.

 

1- Aparece as mensagens de erro de codigo na janelinha de cadastro.

 

2- A conta é criada com sucesso, mas não aparece no Banco de dados que por sinal é o mesmo do Lineage. ( ainda nao vi a logica disso)

 

3- Mesmo com a conta sendo criada com sucesso com aquele erro e estando no banco de dados do l2jdb, não sendo possivel visualizar na tabela, o jogo aceita o login criado.

 

Mt estranho.

 

Andei olhando os sites dos colegas ai do forum e alguns estao funcionando perfeitamente.

 

Outro detalhe:

 

 

O sistema de criação de conta é mt primitivo, embora esteja bem feito. Pq?

 

pq não é feito por sistema de e-mail... o cara cria a conta, esquece a senha ou o login... recupera como?

 

 

O Site está de parabéns, muito bem feito, agradeço por compartilhar!!

 

Mas se possível, poderia concertar esses detalhes que citei acima... digo isso pois nao sou programado, então não tenho a competencia para fazer isso.

 

Muito obrigado e parabéns novamente.

Compartilhar este post


Link para o post
Compartilhar em outros sites

tentei todas as dormas, nenhuma deu certo. tentei ate pegar o script da pagina de cadastro dos servers "l2discovery e l2blackdragonss" postado na pagina 1, mas mesmo assim continua a nao criar conta.

Compartilhar este post


Link para o post
Compartilhar em outros sites
O jeito vai ser instalar esse cara pra ver né.

 

 

Eu uso Xampp no entanto so o erro da pagina de cadastro foi corrigido porem ainda não estao criando acc's..

Fiz as modificaçoes q Ylei citou eh nada tmb..

 

O que pode ser q ta acontecendo?.. ja fucei d+ tentando corrigir isso e nada.. =/

Compartilhar este post


Link para o post
Compartilhar em outros sites
sem mais! show!

 

Sem mais pra vc amigo.

Pra mim ainda não esta 100%.....

 

Em vez de voce tentar mudar de assunto porque n usa do seu conhecimento pra ajudar a galera? Garanto que seria mais util assim! o.O

Editado por Allisson Mateus

Compartilhar este post


Link para o post
Compartilhar em outros sites

O prazado la em cima é PHP master e não perdeia 1 minuto pra resolver esse problema pra gente.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Com o XAMPP funcionou, saiu o erro do php... só que onde ele ta salvando as contas criadas afinal??

Compartilhar este post


Link para o post
Compartilhar em outros sites

Resolvi o problema de criar contas...

Estavamos achando estranho o fato dele criar no mesmo DB do l2, mas é isso mesmo..

O problema??? Apenas um _ ... isso mesmo.. um Underline no codigo rsrsrs

 

Quem quiser a solução me mande PM.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Resolvi o problema de criar contas...

Estavamos achando estranho o fato dele criar no mesmo DB do l2, mas é isso mesmo..

O problema??? Apenas um _ ... isso mesmo.. um Underline no codigo rsrsrs

 

Quem quiser a solução me mande PM.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Laudze desculpa so novo no forum nao sei manda PM to tentando aki ta tando erro... --"

mais c pode manda pra mim e dizer a solucao?

Compartilhar este post


Link para o post
Compartilhar em outros sites

O cara ta morendo pq o cadastro quando faz nao vai pro database com esse site man e simples so voce deixa o server conta autocreate e pronto a no cite quando dar conta sucess.. ele vai loga no server normal e a acc vai aparecer no database ;D THX

Compartilhar este post


Link para o post
Compartilhar em outros sites

=SUBCRIBE=

 

Fazendo dessa meneira, digamos que fica meio tosco o cadastro, não fica legal.

 

Ele nao estava criando a conta no DB pq o INSERT no codigo CADASTRO.PHP está errado... na verdade não é bem um erro.

Os DB do l2jdb nem sempre são iguais.

Meu l2jdb tem na tabela ACCOUNT que tem o campo accesLevel... no INSERT do PHP está mandando inserir o dado AccesLevel no campo Acces_Level.

Como ele não acha esse campo ele simplesmente nao faz INSERT nenhum.

Basta olhar a tabela ACCOUNT e ver como está o AccesLevel e alterar la no CADASTRO.PHP na parte do INSERT.

 

Está +/- na linha 83.

 

Quem mando PM olhe aqui..

 

Espero ter ajudado.

 

Abraçoa todos.

 

 

EDIT: a treta ai no caso pra ficar mais claro foi que no DB ta AccesLevel e no INSERT Acces_Level. Apenas retirei o (underline)

Editado por Laudze

Compartilhar este post


Link para o post
Compartilhar em outros sites
=SUBCRIBE=

 

Fazendo dessa meneira, digamos que fica meio tosco o cadastro, não fica legal.

 

Ele nao estava criando a conta no DB pq o INSERT no codigo CADASTRO.PHP está errado... na verdade não é bem um erro.

Os DB do l2jdb nem sempre são iguais.

Meu l2jdb tem na tabela ACCOUNT que tem o campo accesLevel... no INSERT do PHP está mandando inserir o dado AccesLevel no campo Acces_Level.

Como ele não acha esse campo ele simplesmente nao faz INSERT nenhum.

Basta olhar a tabela ACCOUNT e ver como está o AccesLevel e alterar la no CADASTRO.PHP na parte do INSERT.

 

Está +/- na linha 83.

 

Quem mando PM olhe aqui..

 

Espero ter ajudado.

 

Abraçoa todos.

 

 

EDIT: a treta ai no caso pra ficar mais claro foi que no DB ta AccesLevel e no INSERT Acces_Level. Apenas retirei o (underline)

 

 

 

OMG 1 coisa tao simples e niguem reparou....

Pronto seu Moderador feche o topico agora.. ashushuasuas

Resolvido.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora

Entre para seguir isso  



     



Anuncie em nossa página no Facebook!
Confira o regulamento.
Contate-nos através do e-mail: [email protected] para mais informações.


  • Quem Está Navegando

    Nenhum usuário registrado visualizando esta página.

×