Ir para conteúdo
  • Anúncios

    • AiroN

      Anuncie no L2JBrasil

      Deseja anunciar aqui no fórum, no Top L2JBrasil ou em nossa página no Facebook? Confira: www.l2jbrasil.com/anunciar
    • Grundor

      Método de login alterado   08-10-2017

      Com a atualização do fórum para versão  IPB 4.2 não é mais possível fazer login usando username, ao invés disso você deve usar e-mail ou seu Display Name (nome como é exibido no forum).      
    • AiroN

      Tenha seu clube formalmente no L2JBrasil!   18-10-2017

      Você tem amigos que estão sempre juntos contigo na alegria e na tristeza, na saúde e na doença, em todos os desenvolvimentos de suas vida, no pvp, nas quests? rsrs   Monte seu clube formalmente na L2J Brasil!
      Criar um clube é muito fácil, basta você entrar nesse tópico e se interar do assunto:    Dominem o mundo!


      Atenciosamente,
      Administração L2jBrasil.
SheZ

[Tutorial] Adicionando Custom's no seu Servidor.

Posts recomendados

Ta dando erro aqui tbm =/

ja testei vario file edit mas naum quer abrir.

naum sei qual o problemas pois eu fiz tudo corretamente, so da erro na hora do file editm :dancecat: :wacko:

Compartilhar este post


Link para o post
Compartilhar em outros sites

Ei Alguem Pode Me Ajudar Ta Dando O Mesmo Erro No FileEdit Quando Eu Vou Colocar O Set Sacrifice No Meu Server Sempre Quando Eu Vou Salvar No Desktop Da Erro Se Alguem Puder Me Ajudar Eu Agradeco Flw

Compartilhar este post


Link para o post
Compartilhar em outros sites

veja c os itens q vcx tao querendo add e para a msm versao do cliente

e se tao deixando uma linha vaga no final e salvando em 413.

c der erro e pq o q vc ta tendando adiciona nao para o cliente q vc usa.

Compartilhar este post


Link para o post
Compartilhar em outros sites

mano eu to fazendo tudo certinho adicionei o arkivo sql, colei a xml no local certo ,consegui add o itenname de boa

mas o problema e no weapongrp qdo eu vou "salvar como" da esse erro ai:

se alguem tiver uma luz so falta isso!

vlw obrig ta ai a imagen:

 

apresentao1ao.jpg

Compartilhar este post


Link para o post
Compartilhar em outros sites

Colocou as texturas dentro da pasta systextures... e animações (se vinher) na pasta animations? Lembrou de executar a SQL?

Compartilhar este post


Link para o post
Compartilhar em outros sites
-----------------------------------------------------------------------

Programas Necessarios:

FileEdit: Download Aqui.

-----------------------------------------------------------------------

 

Em primeiro Lugar, escolha o Custom que você quer adicionar em seu Servidor. Clique aqui, e escolha o que você preferir.

 

Começando:

 

Como é um Tutorial, vou usar as Epic Weapons, e a versão do meu Servidor é Gracia Parte2, mas pode ser feito com outros Versões normalmente.

 

1.1 Faça o Download, extraia os Arquivos.

 

foto1cf5.jpg

 

1.2 Abra o seu Navicat, e a table do seu Servidor, no meu caso é l2jdb.

 

foto2vz1.jpg

 

1.3 Clique com o botão direito em cima ta table do seu servidor, no meu caso, à minha é l2jdb, e clique em Execute Batch File...

 

foto3rx6.jpg

 

1.4 Clique nas ... (3 Bolinhas), e procure a SQL do Arquivo Custom que você baixou, e clique em Start.

 

foto4pb3.jpg

 

1.5 Se tudo der certo, o Navicat conseguir carregar a SQL, vai aparecer essa mensagem.

 

foto5on9.jpg

 

1.6 Todo Custom Item, precisar ter um Arquivo XML, pra o Servidor ler ele. (Onde fica os Status do Custom). No caso das Epic Weapons, tem que colar o Arquivo XML, na pasta ...\gameserver\data\stats\weapon.

 

foto6xs9.jpg

 

Número 1: É a Pasta Weapon que eu citei acima. ...\gameserver\data\stats\weapon.

Número 2: É o Arquivo XML, que onde fica os Status das Weapons Epic.

 

Passo 2:

 

- Feito os Passos Acima, e tudo tiver dado certo, então vamos por as Weapons Epic, nos arquivos "itemname-e.dat" e "weapongrp.dat", como meu Servidor é Gracia, vou usar um File Edit Gracia, mas você poderá usar outros, que não haverá herros.

 

1.7 Com o File Edit aberto, abra o Arquivo, "itemname-e.dat", na pasta do Custom Item, é provável que tenha duas pastas.

Server = Onde fica os Arquivos pra Adicionar no Navicat(SQL), e os arquivos XML.

Client - Onde fica os Arquivos em Bloco de Notas, para poder adicionar nos Arquivos da System.

 

foto7yy9.jpg

 

1.8 Como vamos Adicionar primeiro o itemname-e. Abra o itemname-e.txt, sempre comece a selecionar apartir de uma linha abaixo.

 

foto8xy8.jpg

 

1.9 Copiado as linhas da foto acima, e com o File Edit aberto, abra-o itemname-e.dat, da pasta System, e cole-o na ultima linha.

 

foto9pi2.jpg

 

Perceba, que sempre tem que deixar uma linha por último.

 

2.0 Feito o passo de cima, clique no canto esquerdo, em Save and encrypt.

Atenção, no local para Salvar o arquivo, nunca Salve na mesma pasta que você abriu, ou sejá, se você abriu, o itemanem-e.dat, na pasta do seu Client L2, salve ele em outro Lugar, o mais recomendável, na Desktop.

 

foto10tn1.jpg

 

Número 1: Lugar para Salvar o Arquivo, recomendável na Desktop.

Número 2: "Salvar como tipo:" sempre coloque Dat Files.

Número 3: Sempre Salve como 413.

 

2.1 Clique em foto11oz6.jpg para Salvar, se nada aparecer, é que tudo deu certo. Então copie o arquivo que foi Salvo e cole na System, e o Custom que você escolher já vai estar Adicionado.

 

2.2 Isso vale também, para os arquivos, "weapongrp.dat", "armorgrp.dat", entre outros.

 

Creditos: SheZ ® AllRights Reserved.

 

 

 

 

Proibida a reprodução mesmo que em partes desse tutorial sem a publicação dos devidos créditos de criação

Garantido pela Constituição da República Federativa do Brasil, de 05 de outubro de 1988

Portaria MCT n° 88, de 23/04/98

Propriedade Intelectual

Compartilhar este post


Link para o post
Compartilhar em outros sites

o meu tb ta com esse erro eu add no itenname-e foi de boa agora no weapon grp e armor grp fica com o mesmo erro do cara ae do print

ja abaixei os ids todos menores possiveis ja executei o sql os arquivo xml tudo de boa so essa parada ae que nao estou coneguino fazer

se algume puder ajudar fico esperando Neh!

Compartilhar este post


Link para o post
Compartilhar em outros sites

o meu tb ta com esse erro eu add no itenname-e foi de boa agora no weapon grp e armor grp fica com o mesmo erro do cara ae do print

ja abaixei os ids todos menores possiveis ja executei o sql os arquivo xml tudo de boa so essa parada ae que nao estou coneguino fazer

se algume puder ajudar fico esperando Neh!

Compartilhar este post


Link para o post
Compartilhar em outros sites

MANOS EU FUI ADD AS ARMAS NO MEU SERVE. EU ADD NA ITEMNAME-E MAIS NA HORA DE EU ADD OS NEGOCIOS NA WEAPONGRP DEU ERRO ESSE AKI O

" CANNOT OPEN FILE C:/ ...WEAPONGRP . O SYSTEMA NAO PODE ENCONTRAR O ARQUIVO ESPECIFICADO. OQ EU FACO???

Compartilhar este post


Link para o post
Compartilhar em outros sites

IXI QUANDO DA ESSE ERRO NAO TEM CONCERTO É PQ AS LINHA DO WEAPONGRP DA ARMA NAO BATE COM A TABELA DO CLIENTE O JEITO É VC DESISTI OU TENTA ALINHA TODAS LINHAS NA TABELA Q É UM SACRIFICIO

Compartilhar este post


Link para o post
Compartilhar em outros sites

Aew pessoal...

 

alguem sabe como tirar o "<releated to quest> (nome da quest)"?

 

se alguem souber, por favor...

me fala!!

 

obrigado!

Compartilhar este post


Link para o post
Compartilhar em outros sites

olha!

tenho uma duvida aki!!

tipow!

coloquei alguns custons... alguns funfaram outros naum... tipo

fiz tudo q ta ai no tuto.. e tud deu certo. mas na hora de criar o item ele diz q o item foi criado mas nao aparece no meu inventario...

como resolvo????

Compartilhar este post


Link para o post
Compartilhar em outros sites
Aew pessoal...

 

alguem sabe como tirar o "<releated to quest> (nome da quest)"?

 

se alguem souber, por favor...

me fala!!

 

obrigado!

 

N TEM ND A VER COM ESSE TUTORIAL TENTE FAZER ESSA PERGUNTA AQUI!

 

http://www.l2jbrasil.com/index.php?showforum=18

 

 

olha!

tenho uma duvida aki!!

tipow!

coloquei alguns custons... alguns funfaram outros naum... tipo

fiz tudo q ta ai no tuto.. e tud deu certo. mas na hora de criar o item ele diz q o item foi criado mas nao aparece no meu inventario...

como resolvo????

 

é pq vc n adcinou o armorgrp ou weapongrp correcto ou pode ter dado erro na hora de adcionar no navicat ou vc nao adicionou os html devidamente vc tem que comfirmar tudo issu!

 

 

 

Estou com umk problema, que todo custom que baixei nao veio com XML, poderia ser com outra arquivo?

 

quais customs vc baixou e que xml vc ta referindo das multisell?

Compartilhar este post


Link para o post
Compartilhar em outros sites

 

Opa, blz??

olha soh, eu fiz uma vez e deu certo... porém

quando eu fui fazer na segunda deu um erro no mesmo file edit

q eu utilizei da primeira vez...

 

#erro abaixo

errofileedit.th.png

Link direto da img

 

oq eu faço pra não dar mais este erro???

 

Desde jah agradeço...

vlw teh mais!!!

abraço!

----edit---

pra add quote =)

Editado por CoelhOeLemeZ

Compartilhar este post


Link para o post
Compartilhar em outros sites

geralmente quando acontece esse erro é porque o ID está duplicado, ou o que você está tentando adicionar tem alguma coisa errada ou não é pro seu client

Compartilhar este post


Link para o post
Compartilhar em outros sites

geralmente quando acontece esse erro é porque o ID está duplicado, ou o que você está tentando adicionar tem alguma coisa errada ou não é pro seu client

 

eh mais eu jah troquei os client, jah tentei com amorgrp.dat de outras versões, tenho todos file edit menos o gracia, a path e o sv q to usanu eh CT2 e continua dando o mesmo erro!!!

sendo q jah fiz isso uma vez e deu certo ¬¬'

 

o q será q eh??? =/

Compartilhar este post


Link para o post
Compartilhar em outros sites

poxa todos os itens q eu add aparece com o nome noitenname alguem em ajdua

Editado por Josue

Compartilhar este post


Link para o post
Compartilhar em outros sites



     


  • Quem Está Navegando

    Nenhum usuário registrado visualizando esta página.

×