Jump to content
  • 0
Andrey156

Npc training dummy andando

Question

Ae galera, tudo bem, estou com um problema naquele npc que colocamos pra os player baterem, o Training Dummy, ele está andando quando batemos nele, mesmo que eu coloque-o pra ficar fixo, com comando do adm, com um tempo ele volta a andar, quando da restart no servidor ele vai pra o cantinho dele la, mas logo quando alguém bate, ele anda, será que alguém pode ajudar ae!?

Segue imagem:

Dummy.png

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0
18 horas atrás, NetinhOO disse:

Boa noite, você adicionou alguma walk_routers nele?

Não amigo, só peguei o id, e spawnei ele em giran, vou dar uma olhada nisso, vlw!!

Share this post


Link to post
Share on other sites
  • 0
10 horas atrás, BySouza disse:

Você quer deleta o npc de onde você deu Spawn nele ou você quer que ele não ande quando atacado?

Amigo, quero que ele fique parado enquanto bate nele, quero que os players batam nele, e ele fique paradinho lá!

Share this post


Link to post
Share on other sites
  • 0
16 horas atrás, Andrey156 disse:

Amigo, quero que ele fique parado enquanto bate nele, quero que os players batam nele, e ele fique paradinho lá!

Tente fazer uma copia dele com outro ID 

Copia a SQL ou a XML dele e troca o ID e cria um novo NPC e ve se acontece o mesmo

Caso aconteça, tenta atacar npcs normais do jogo 

Coloque a velocidade que ele anda pra 0 também

  • Like 1

www.l2jservidores.com.br

Interlude / Freya / High Five

Share this post


Link to post
Share on other sites
  • 0
2 horas atrás, Elesis disse:

Tente fazer uma copia dele com outro ID 

Copia a SQL ou a XML dele e troca o ID e cria um novo NPC e ve se acontece o mesmo

Caso aconteça, tenta atacar npcs normais do jogo 

Coloque a velocidade que ele anda pra 0 também

O problema não é isso, é o que o @NetinhOO falou, esse npc está com rotas pré determinadas, vá no data base e procura a tabela que o netinho citou ela pode estar com esse nome ou o nome de npc_walker, algo assim com walker, abra e procure pelo id's do npc, achando delete todas as rotas para esse npc.

  • Thanks 1

pD5PSQp.png

" Você nunca sabe que resultados virão de suas ações, mas se você não fizer nada, não existirão resultados"

 

 

Share this post


Link to post
Share on other sites
  • 0
4 horas atrás, Elesis disse:

Tente fazer uma copia dele com outro ID 

Copia a SQL ou a XML dele e troca o ID e cria um novo NPC e ve se acontece o mesmo

Caso aconteça, tenta atacar npcs normais do jogo 

Coloque a velocidade que ele anda pra 0 também

Isso já resolveria o problema.

 

1 hora atrás, MrFreedomFights disse:

O problema não é isso, é o que o @NetinhOO falou, esse npc está com rotas pré determinadas, vá no data base e procura a tabela que o netinho citou ela pode estar com esse nome ou o nome de npc_walker, algo assim com walker, abra e procure pelo id's do npc, achando delete todas as rotas para esse npc.

E isso também resolveria o problema, caso seja isto.

 

Outra coisa bem simples, apenas verifique qual o type do npc, depois disso caso ele não esteja como "default" aplique esse type nele. Ah, as dicas acimas são ótimas também, vale apena conferir.


Masturbe sua mente, goze suas ideias.

Share this post


Link to post
Share on other sites
  • 0
3 horas atrás, BySouza disse:

Isso já resolveria o problema.

 

E isso também resolveria o problema, caso seja isto.

 

Outra coisa bem simples, apenas verifique qual o type do npc, depois disso caso ele não esteja como "default" aplique esse type nele. Ah, as dicas acimas são ótimas também, vale apena conferir.

eu botei defaut como vc falou e os npc foram deletados ai botei monster de novo e os npc voltaram

5 horas atrás, MrFreedomFights disse:

O problema não é isso, é o que o @NetinhOO falou, esse npc está com rotas pré determinadas, vá no data base e procura a tabela que o netinho citou ela pode estar com esse nome ou o nome de npc_walker, algo assim com walker, abra e procure pelo id's do npc, achando delete todas as rotas para esse npc.

nao tenho essa tabela no meu server

Share this post


Link to post
Share on other sites
  • 0
8 horas atrás, Elesis disse:

Tente fazer uma copia dele com outro ID 

Copia a SQL ou a XML dele e troca o ID e cria um novo NPC e ve se acontece o mesmo

Caso aconteça, tenta atacar npcs normais do jogo 

Coloque a velocidade que ele anda pra 0 também

ja botei como velocidade 0 mais mesmo a sim ele anda

Share this post


Link to post
Share on other sites
  • 0

ainda com o mesmo problema eu fiz uma copia mais mesmo a sim nao adianta

Em 15/09/2019 at 01:02, NetinhOO disse:

Vou te recomendar o que recomendei em outro post: duplique o NPC e veja se funcionou, nunca tive problemas com esse npc.

eu fiz uma copia botei ele para andar 0, ele fica la paradao mais quando 1 ply atk o npc ele sai andando a tras do plys.

Edited by kammilo

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...




     



×
×
  • Create New...