Jump to content
vert

L2JBlueHeart 💙

Recommended Posts

20 minutos atrás, vert disse:

de vcs ta a sim tbm vc ussa dressme pega normal mas quando desloga e loga ele sai

 

20 minutos atrás, vert disse:

É assim mesmo.

Existe a possibilidade de manter permanente desativando apenas no .dressme opção de remover ou por exemplo 7/30 dias?

Edited by alexfabiano

Share this post


Link to post
Share on other sites
9 minutos atrás, alexfabiano disse:

 

Existe a possibilidade de manter permanente ou por exemplo 7/30 dias?

Pelo que andei olhando no código agora, ele deveria manter a aparência sim, vamos verificar; da pra usar o sistema assim, porém, assim que puder iremos lançar a correção;

  • Like 3
  • Thanks 3

Share this post


Link to post
Share on other sites
2 horas atrás, vert disse:

Pelo que andei olhando no código agora, ele deveria manter a aparência sim, vamos verificar; da pra usar o sistema assim, porém, assim que puder iremos lançar a correção;

 

Hum quanto a isso, acho que é um bug mesmo no codigo, ao dar restart depois de usar um dressme ele não salva o visual do personagem in-game mas salva na tela de login!

Olha umas prints ai!

 

print.jpg?1533843882print.jpg?1533843882

Edited by Azazyel
  • Like 1
  • Sad 1

Share this post


Link to post
Share on other sites
8 minutos atrás, Azazyel disse:

 

Hum quanto a isso, acho que é um bug mesmo no codigo, ao dar restart depois de usar um dressme ele não salva o visual do personagem in-game mas salva na tela de login!

Olha umas prints ai!

  Ocultar conteúdo

print.jpg?1533843882print.jpg?1533843882

Sim, eu notei isso, quando vi esse comportamento (após o rapaz perguntar), verifiquei no banco e lá estava certinho o id do item que deveria exibir a aparência, eu ou o @TurtleLess iremos verificar e assim que possível, postar a correção;

  • Like 5

Share this post


Link to post
Share on other sites
14 hours ago, vert said:

Sim, eu notei isso, quando vi esse comportamento (após o rapaz perguntar), verifiquei no banco e lá estava certinho o id do item que deveria exibir a aparência, eu ou o @TurtleLess iremos verificar e assim que possível, postar a correção;

Esse erro é facil. Eu tbm adaptei esse codigo para a minha rev. Se vc quer uma dica, é pq ele não está salvando corretamente no database. vc Tem que editar 2 linhas. Agora quais são é a você a achar. Elas tem algo a ver com salvamento de dados. Boa sorte!


"Sua vida é uma caixinha de surpresas, abra ela e descrubra o que está para vir"

By: Anonimo

"Um amigo, é somente o seu inimigo que não te atacou ainda!"

By: Anonimo

Share this post


Link to post
Share on other sites

e na tela de login, acho que em nenhum dressme funciona. Pois ele pega outros modelos dos items... Mas é,  ve ai^^


"Sua vida é uma caixinha de surpresas, abra ela e descrubra o que está para vir"

By: Anonimo

"Um amigo, é somente o seu inimigo que não te atacou ainda!"

By: Anonimo

Share this post


Link to post
Share on other sites
12 horas atrás, alexfabiano disse:

Cara se eu manjasse dos "parana uê" ajudava to tentando corrigir aqui mas ainda sou leigo sobre essas paradas ?

Sem problemas, testando e reportando bugs já é uma ajuda bem grande;

9 horas atrás, Reign disse:

@vert e @TurtleLess eu comendo usar essa geodata até que encontrem uma melhor, nenhuma geodata resolveu o problema do Underground Coliseum de Fantasy Island, então não usem essa área!

Beleza @Reign, poderia upar ela no media fire ou em algum outro servidor e comentar o link ? Ai eu coloco no post principal junto com o download da rev;

 

1 hora atrás, marciox25 disse:

Esse erro é facil. Eu tbm adaptei esse codigo para a minha rev. Se vc quer uma dica, é pq ele não está salvando corretamente no database. vc Tem que editar 2 linhas. Agora quais são é a você a achar. Elas tem algo a ver com salvamento de dados. Boa sorte!

 

1 hora atrás, marciox25 disse:

e na tela de login, acho que em nenhum dressme funciona. Pois ele pega outros modelos dos items... Mas é,  ve ai^^

 

Hum, vamos dar uma olhada, 

Poderia ser mais específico por gentileza ?

Se for isso mesmo que disse, como está o seu DressMeHandler.java ? Poderia postar o código só dele por favor ?

Obrigado

Edited by vert
  • Like 4

Share this post


Link to post
Share on other sites
3 hours ago, vert said:

Sem problemas, testando e reportando bugs já é uma ajuda bem grande;

Beleza @Reign, poderia upar ela no media fire ou em algum outro servidor e comentar o link ? Ai eu coloco no post principal junto com o download da rev;

 

 

 

Hum, vamos dar uma olhada, 

Poderia ser mais específico por gentileza ?

Se for isso mesmo que disse, como está o seu DressMeHandler.java ? Poderia postar o código só dele por favor ?

Obrigado

Eu ja olhei e o seu e completamente diferente do que eu tenho. O seu é praticamente 3 arquivos diferenciados. O meu é somente Um. Mas não esta nele o erro. O problema esta no L2ItemInstance

  • Like 1

"Sua vida é uma caixinha de surpresas, abra ela e descrubra o que está para vir"

By: Anonimo

"Um amigo, é somente o seu inimigo que não te atacou ainda!"

By: Anonimo

Share this post


Link to post
Share on other sites
3 minutos atrás, marciox25 disse:

Eu ja olhei e o seu e completamente diferente do que eu tenho. O seu é praticamente 3 arquivos diferenciados. O meu é somente Um. Mas não esta nele o erro. O problema esta no L2ItemInstance

Sim, eu sei, já identifiquei o problema;

Obrigado;

Estou trabalhando na correção;

  • Like 4
  • LOL 1

Share this post


Link to post
Share on other sites

 

3 horas atrás, vert disse:

Sem problemas, testando e reportando bugs já é uma ajuda bem grande;

Eu encontrei uns errinhos no dressme questão visual no painel porém assim que esse problema for resolvido eu reporto para não sobrecarregar as correções! Uma coisa de cada vez rsrs...

Adicionei uns items de visual bacanas aguardando a correção.

  • Like 1

Share this post


Link to post
Share on other sites

Guys, 

O código não estava com problema, estava apenas incompleto, faltava uma parte bem simples e eu desenvolvi hoje no almoço;

 

o .undressme está funcionando (ele envia uma html para o player, é só editar a html galera, não testei todos os comandos mas acredito que possam estar assim também);

 

Observações:

Ao passar o item pra outro player, ele continuará com a aparência (porque está salvo no banco de dados no object id);

- Quero voltar a aparência do meu item, como eu faço ?

Há duas formas: comprar a aparência do item de novo pelo dress me (acho meio inviável), ou jogar o item no chão e pegar (ele vai continuar com a aparência porque está instanciado já, mas ao dar RR no char, o item volta com a aparência normal... Porquê ? Porque ao jogar o item no chão, ele é excluído da tabela items e fica apenas no cache e na instancia do servidor, ao pegar o item, ele cria um item novo, sem referencia do dress me;

 

Pessoal, a Att já está no github, é só pegar o core.jar e substituir na revisão de vocês;

  • Like 4

Share this post


Link to post
Share on other sites
Agora, vert disse:

Quero voltar a aparência do meu item, como eu faço ?

Basta abrir o dressme novamente ir na última opção: Remove visual effect 

Escolher o que vc quer remover o visual e pronto!

Edited by alexfabiano
  • Thanks 2

Share this post


Link to post
Share on other sites
1 minuto atrás, alexfabiano disse:

Basta abrir o dressme novamente ir na última opção: Remove visual effect 

Escolher o que vc quer remover o visual e pronto!

Obrigado fera, como eu disse, não testei todos os comandos, apenas implementei o mod no projeto e estou corrigindo o que vocês reportam ? 

  • Like 3
  • Thanks 2

Share this post


Link to post
Share on other sites
1 minuto atrás, alexfabiano disse:

Olha só usando a opção Remove visual effect eu estava usando um set Heavy para pegar um visual heavy para testes... ok, aí quando removi o visual meu char ficou com visual Elegia Robe e não com o visual do set Heavy que estava equipado.

 

Ite1Cts.png

Já o problema no painel dressme é a opção de Hat que está com o simbolo do escudo e não de um Hat de fato...

p0qmkzp.png

Tenho que resolver s coisas mais tarde vejo se tem + algum problema!

Vlw! ?

beleza, 

ele fica com o visual do elegia robe mesmo se der rr ?

depois eu ou o TurtLess vamos dar uma olhada;

Obrigado

  • Like 3

Share this post


Link to post
Share on other sites
Agora, vert disse:

ele fica com o visual do elegia robe mesmo se der rr ?

Sim é como se eu tivesse trocado do visual que eu estava usando pelo visual robe elegia que nem ta no dressme... Acredito que tenha algo a ver com a classe de mago que normalmente usa robe. Acho que o dressme ta configurado para voltar pro elegia robe se vc estiver de mago independente do set equipado... Posso estar errado mas vê ai ?

Share this post


Link to post
Share on other sites
3 minutos atrás, alexfabiano disse:

Sim é como se eu tivesse trocado do visual que eu estava usando pelo visual robe elegia que nem ta no dressme... Acredito que tenha algo a ver com a classe de mago que normalmente usa robe. Acho que o dressme ta configurado para voltar pro elegia robe se vc estiver de mago independente do set equipado... Posso estar errado mas vê ai ?

Testa mais por favor; 

Usa outros sets, outras opções, preciso de mais informações e de algo certo de que está errado;

Ta bom ? Valeu fera

  • Like 4

Share this post


Link to post
Share on other sites
1 hora atrás, alexfabiano disse:

Sim é como se eu tivesse trocado do visual que eu estava usando pelo visual robe elegia que nem ta no dressme... Acredito que tenha algo a ver com a classe de mago que normalmente usa robe. Acho que o dressme ta configurado para voltar pro elegia robe se vc estiver de mago independente do set equipado... Posso estar errado mas vê ai ?

 

1 hora atrás, vert disse:

Testa mais por favor; 

Usa outros sets, outras opções, preciso de mais informações e de algo certo de que está errado;

Ta bom ? Valeu fera

 

@alexfabiano Presta mais atenção, você está postando muito coisa que não são erros, apenas falta de atenção, eu testei com todos os sets s80+ e não acontece isso de usar Elegia Heavy e no undressme virar Elegia Robe!

O erro no seu report está que todos os sets Heavy, Light ou Robe Grade S80+, ficam com a mesma aparencia em um personagem Human Wizard, assim como nos Dwarf, qualquer set S80+ fica Heavy, isso foi apenas um modo que eu acho que os desenvolvedores escolheram de economizar linhas na hora da criação das texturas!
 

Algumas Prints:

 

PRINT.jpg?1533929581

Edited by Azazyel
  • Unlike 1
  • Thanks 1

Share this post


Link to post
Share on other sites
2 horas atrás, Azazyel disse:

Presta mais atenção

Acredito que minha intenção era passar mesmo que de forma leiga algo que eu acho que estava errado (continuo achando isso) e em momento nenhum pedi a alguém para se ocupar com tais tarefas.

Se o @vert ou o @TurtleLess se sentiu incomodado peço desde já desculpas e já me calo.

Por outro lado o tempo que eu tenho não gasto me incomodando com posts que eu não concordo. Até mando pm de preferência pq não curto idiotices nos tópicos enfim...

@vert ou o @TurtleLess Qualquer coisa mandarei pm esta é uma das razões por eu ter poucos posts...?

4 horas atrás, vert disse:

Testa mais por favor; 

Como eu havia dito tive que resolver problemas por isso não sei se de fato vai ter + algo...

Share this post


Link to post
Share on other sites
33 minutos atrás, alexfabiano disse:

Acredito que minha intenção era passar mesmo que de forma leiga algo que eu acho que estava errado (continuo achando isso) e em momento nenhum pedi a alguém para se ocupar com tais tarefas.

Se o @vert ou o @TurtleLess se sentiu incomodado peço desde já desculpas e já me calo.

Por outro lado o tempo que eu tenho não gasto me incomodando com posts que eu não concordo. Até mando pm de preferência pq não curto idiotices nos tópicos enfim...

@vert ou o @TurtleLess Qualquer coisa mandarei pm esta é uma das razões por eu ter poucos posts...?

Como eu havia dito tive que resolver problemas por isso não sei se de fato vai ter + algo...

Mano, você tem ajudado bastante, ter sugerido o mod de dressme foi bem legal da sua parte;

Prefiro que poste aqui coisas relacionadas a revisão (porque assim o tópico continua em destaque);

 

Sempre que  você ou algum membro posta algo, seja bug ou sugestão, eu e o Turtle lemos e conversamos sobre, se é bug, nós já corremos pra tentar resolver pra vocês;

Então se for reportar algo, pode reportar de boas, nós agradecemos bastante, mas testa bem testado por favor, porque nós nos empenhamos bastante pra resolver os bugs rápidos e nem sempre temos tempo, então quando postam algo, sempre levamos a sério;

 

Acredito que seja isso que o Aza tentou dizer em outras palavras, do jeito dele;

 

Mais uma vez, muito obrigado pela sua ajuda, seria um prazer continuar tendo seus posts no tópico, só peço que ao reportar algo, tenha certeza (testar) pra gente já poder ir mexer e não ser alarme falso xD

  • Like 5

Share this post


Link to post
Share on other sites
3 horas atrás, alexfabiano disse:

Acredito que minha intenção era passar mesmo que de forma leiga algo que eu acho que estava errado (continuo achando isso) e em momento nenhum pedi a alguém para se ocupar com tais tarefas.

Se o @vert ou o @TurtleLess se sentiu incomodado peço desde já desculpas e já me calo.

Por outro lado o tempo que eu tenho não gasto me incomodando com posts que eu não concordo. Até mando pm de preferência pq não curto idiotices nos tópicos enfim...

@vert ou o @TurtleLess Qualquer coisa mandarei pm esta é uma das razões por eu ter poucos posts...?

Como eu havia dito tive que resolver problemas por isso não sei se de fato vai ter + algo...

@alexfabiano não quis te ofender brother, mas não se se você está a muito tempo no forum, se tiver deve saber que os adm's gostam de chamar a atenção por bobagens, e quando alongamos muito um mesmo assunto eles costumam chamar atenção, fizeram isso aqui mesmo no tópico na pagina 3, o Escanor já chamou a atenção!

Share this post


Link to post
Share on other sites

Percebi que alguns buffs importantes +15 e +30 (Todos os resists + outros) estavam configurados no npc buffer, então não teria sentido em adquirir o item AIO, então fiz umas mudanças nos buffs do npc deixando todos +0 e adicionei o Freezing/Blaazing Skin +30, Pride of Kamael +30, Combat Aura e Nobles no AIO. -> Download

E também queria saber se o anuncio de eventos está bugado ou apenas não encontrei onde configurar ele, os evento mesmo ativos não estão sendo anunciados.

Edited by Reign
  • I love it 1
  • Thanks 1

Share this post


Link to post
Share on other sites




     



×
×
  • Create New...